armadillo 12.4.2
C++ linear algebra library
Armadillo is a C++ linear algebra library, aiming towards a good balance between speed and ease of use. It is useful for algorithm development directly in C++, or quick conversion of research code into production environments. It can be used for machine learning, pattern recognition, signal processing, bioinformatics, statistics, econometrics, etc. The library provides efficient classes for vectors, matrices and cubes, as well as 150+ associated functions (e.g., contiguous and non-contiguous submatrix views).
- Outputs:
out
- Website: https://arma.sourceforge.net/
- Licenses: ASL 2.0
- Package source: gnu/packages/maths.scm
- Builds: See build status
- Issues: See known issues
Installation
Install armadillo 12.4.2
as follows:
guix install armadillo@12.4.2
Or install the latest version:
guix install armadillo
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.