avr-gdb 14.2
The GNU Debugger for AVR
GDB is the GNU debugger. With it, you can monitor what a program is doing while it runs or what it was doing just before a crash. It allows you to specify the runtime conditions, to define breakpoints, and to change how the program is running to try to fix bugs.
This variant of GDB can be used to debug programs written for the AVR microcontroller architecture.
- Outputs:
debug
,out
- Website: https://www.gnu.org/software/gdb/
- Licenses: GPL 3+
- Package source: gnu/packages/gdb.scm
- Builds: See build status
- Issues: See known issues
Installation
Install avr-gdb 14.2
as follows:
guix install avr-gdb@14.2
Or install the latest version:
guix install avr-gdb
The avr-gdb
package provides more outputs besides the default (out
). You can install them by appending :output-name
to the package specification. For example:
guix install avr-gdb:debug
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.