bearssl 0.6
Small SSL/TLS library
BearSSL is an implementation of the SSL/TLS protocol (RFC 5246) written in C. It aims at being correct and secure. In particular, insecure protocol versions and choices of algorithms are not supported, by design; cryptographic algorithm implementations are constant-time by default. It should also be small, both in RAM and code footprint. For instance, a minimal server implementation may fit in about 20 kilobytes of compiled code and 25 kilobytes of RAM.
- Website: https://bearssl.org/
- Licenses: Expat
- Package source: gnu/packages/tls.scm
- Builds: See build status
- Issues: See known issues
Installation
Install bearssl 0.6
as follows:
guix install bearssl@0.6
Or install the latest version:
guix install bearssl
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.