This package browser is in early development. Mind the rough edges.

bool

Finding text and HTML files that match boolean expressions

GNU Bool is a utility to perform text searches on files using Boolean expressions. For example, a search for "hello AND world" would return a file containing the phrase "Hello, world!". It supports both AND and OR statements, as well as the NEAR statement to search for the occurrence of words in close proximity to each other. It handles context gracefully, accounting for new lines and paragraph changes. It also has robust support for parsing HTML files.

Installation

Install the latest version of bool as follows:

guix install bool

Or install a particular version:

guix install bool@0.2.2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.