botan
Cryptographic library in C++11
Botan is a cryptography library, written in C++11, offering the tools necessary to implement a range of practical systems, such as TLS/DTLS, PKIX certificate handling, PKCS#11 and TPM hardware support, password hashing, and post-quantum crypto schemes. In addition to the C++, botan has a C89 API specifically designed to be easy to call from other languages. A Python binding using ctypes is included, and several other language bindings are available.
- Versions: 2.19.3
- Website: https://botan.randombit.net
- Licenses: FreeBSD
- Package source: gnu/packages/crypto.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of botan
as follows:
guix install botan
Or install a particular version:
guix install botan@2.19.3
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.