This package browser is in early development. Mind the rough edges.

check

Unit test framework for C

Check is a unit testing framework for C. It features a simple interface for defining unit tests, putting little in the way of the developer. Tests are run in a separate address space, so Check can catch both assertion failures and code errors that cause segmentation faults or other signals. The output from unit tests can be used within source code editors and IDEs.

Installation

Install the latest version of check as follows:

guix install check

Or install a particular version:

guix install check@0.12.0

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

HTML: <a href='http://127.0.0.1:3000/packages/check/'><img src='http://127.0.0.1:3000/packages/check/badges/latest-version.svg'></img></a>
Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/check/badges/latest-version.svg)](http://127.0.0.1:3000/packages/check/)
Org: [[http://127.0.0.1:3000/packages/check/][http://127.0.0.1:3000/packages/check/badges/latest-version.svg]]