chez-scheme-for-racket
Variant of Chez Scheme extended for Racket
This variant of Chez Scheme is extended to support the implementation of Racket. It may be useful on platforms that are not yet supported by upstream Chez Scheme.
Main additions to Chez Scheme in the Racket variant:
AArch64 and RV64G (RISC-V) code generation
Portable bytecode (
pb
) mode, which is mainly useful for bootstrapping a build on any platform, but can also be used on platforms without native-code generation, compiled via Emscripten, linked withlibffi
, or used with bytecode partially compiled to CUnboxed floating-point arithmetic and flvectors
Faster multiplication and division for large exact numbers
Type reconstruction during optimization (especially for safe code)
Continuation marks
Parallel garbage collection, in-place garbage collection for old-generation objects (instead of always copying), and reachability-based memory accounting
Ordered finalization, immobile (but collectable) objects, weak/ephemeron generic hash tables, and reference bytevectors
Easier bootstrapping via old versions of Chez Scheme
- Versions: 9.9.9-pre-release.14
- Website: https://github.com/racket/ChezScheme
- Licenses: ASL 2.0
- Package source: gnu/packages/chez.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of chez-scheme-for-racket
as follows:
guix install chez-scheme-for-racket
Or install a particular version:
guix install chez-scheme-for-racket@9.9.9-pre-release.14
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.