This package browser is in early development. Mind the rough edges.

cl-concrete-syntax-tree

Parse Common Lisp code into a concrete syntax tree

This library is intended to solve the problem of source tracking for Common Lisp code.

By "source tracking", it is meant that code elements that have a known origin in the form of a position in a file or in an editor buffer are associated with some kind of information about this origin.

Since the exact nature of such origin information depends on the Common Lisp implementation and the purpose of wanting to track that origin, the library does not impose a particular structure of this information. Instead, it provides utilities for manipulating source code in the form of what is called concrete syntax trees (CSTs for short) that preserve this information about the origin.

Installation

Install the latest version of cl-concrete-syntax-tree as follows:

guix install cl-concrete-syntax-tree

Or install a particular version:

guix install cl-concrete-syntax-tree@0.2.0-0.3729172

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.