cl-containers
Container library for Common Lisp
Common Lisp ships with a set of powerful built in data structures including the venerable list, full featured arrays, and hash-tables. CL-containers enhances and builds on these structures by adding containers that are not available in native Lisp (for example: binary search trees, red-black trees, sparse arrays and so on), and by providing a standard interface so that they are simpler to use and so that changing design decisions becomes significantly easier.
- Versions: 0.12.1-3.3d1df53
- Website: https://common-lisp.net/project/cl-containers/
- Licenses: Expat
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-containers
as follows:
guix install cl-containers
Or install a particular version:
guix install cl-containers@0.12.1-3.3d1df53
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.