This package browser is in early development. Mind the rough edges.

cl-exit-hooks

Call functions automatically when Common Lisp exits

exit-hooks provides a portable way to automatically call some user-defined function when exiting Common Lisp (both quit from the REPL or a kill in a shell). Like atexit in C and Python or Java’s Runtime.addShutdownHook(). It currently supports SBCL, CCL, ECL, ABCL, Allegro CL, clisp and CMUCL. Before exit-hooks, there was no portable way of doing so and no staightforward way to use an exit hook on ABCL. It can be used for tasks like parmenantly save something when exiting Lisp.

Installation

Install the latest version of cl-exit-hooks as follows:

guix install cl-exit-hooks

Or install a particular version:

guix install cl-exit-hooks@0.0.0-1.78050f4

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.