cl-fxml
XML parser and serializer in Common Lisp
FXML is a secure-by-default, error-recovering XML parser and serializer. It is a fork of CXML.
You should use FXML instead of CXML if:
You are parsing potentially ill-formed XML.
You are parsing potentially malicious XML.
You need to use Klacks with namespaces.
FXML’s API is very close to CXML's, and for the most part you can refer to the CXML documentation for usage.
- Versions: 0.0.0-1.a0e73bb
- Website: https://github.com/ruricolist/fxml
- Licenses: LLGPL
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-fxml
as follows:
guix install cl-fxml
Or install a particular version:
guix install cl-fxml@0.0.0-1.a0e73bb
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/cl-fxml/'><img src='http://127.0.0.1:3000/packages/cl-fxml/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/cl-fxml/badges/latest-version.svg)](http://127.0.0.1:3000/packages/cl-fxml/) Org: [[http://127.0.0.1:3000/packages/cl-fxml/][http://127.0.0.1:3000/packages/cl-fxml/badges/latest-version.svg]]