cl-nactivitypub
Common Lisp implementation of ActivityPub and ActivityStreams standards
This package provides a Common Lisp implementation of ActivityPub and ActivityStreams standards for social networking.
Features:
Parsing and un-parsing ActivityStreams JSON-LD objects to/from CLOS objects with convenient accessors on those.
Sending and fetching ActivityStreams objects to/from the ActivityStreams-enabled HTTP(S) URLs.
Semantic info extraction with methods like
name*
,url*
,author*
, andpublished*
.No reliance on JSON parser.
njson
is used for parser-independent JSON handling. Load the parser backend you prefer!
- Versions: 0.0.5
- Website: https://github.com/atlas-engineer/nactivitypub
- Licenses: Modified BSD
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-nactivitypub
as follows:
guix install cl-nactivitypub
Or install a particular version:
guix install cl-nactivitypub@0.0.5
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.