This package browser is in early development. Mind the rough edges.

cl-nactivitypub 0.0.5

Common Lisp implementation of ActivityPub and ActivityStreams standards

This package provides a Common Lisp implementation of ActivityPub and ActivityStreams standards for social networking.

Features:

  • Parsing and un-parsing ActivityStreams JSON-LD objects to/from CLOS objects with convenient accessors on those.

  • Sending and fetching ActivityStreams objects to/from the ActivityStreams-enabled HTTP(S) URLs.

  • Semantic info extraction with methods like name*, url*, author*, and published*.

  • No reliance on JSON parser. njson is used for parser-independent JSON handling. Load the parser backend you prefer!

Installation

Install cl-nactivitypub 0.0.5 as follows:

guix install cl-nactivitypub@0.0.5

Or install the latest version:

guix install cl-nactivitypub

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.