cl-num-utils
Numerical utilities for Common Lisp
cl-num-utils
implements simple numerical functions for Common Lisp, including:
num=
, a comparison operator for floatssimple arithmeric functions, like
sum
andl2norm
elementwise operations for arrays
intervals
special matrices and shorthand for their input
sample statistics
Chebyshev polynomials
univariate rootfinding
- Versions: 0.1-1.97a88cd
- Website: https://github.com/tpapp/cl-num-utils
- Licenses: Boost 1.0
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-num-utils
as follows:
guix install cl-num-utils
Or install a particular version:
guix install cl-num-utils@0.1-1.97a88cd
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/cl-num-utils/'><img src='http://127.0.0.1:3000/packages/cl-num-utils/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/cl-num-utils/badges/latest-version.svg)](http://127.0.0.1:3000/packages/cl-num-utils/) Org: [[http://127.0.0.1:3000/packages/cl-num-utils/][http://127.0.0.1:3000/packages/cl-num-utils/badges/latest-version.svg]]