clang-runtime
Runtime library for Clang/LLVM
The "clang-runtime" library provides the implementations of run-time functions for C and C++ programs. It also provides header files that allow C and C++ source code to interface with the "sanitization" passes of the clang compiler. In LLVM this library is called "compiler-rt".
- Versions: 9.0.1 · 8.0.1 · 7.1.0 · 6.0.1 · 3.9.1 · 3.8.1 · 3.7.1 · 3.5.2 · 20.1.2 · 19.1.7 · 18.1.8 · 17.0.6 · 16.0.6 · 15.0.7 · 14.0.6 · 13.0.1 · 12.0.1 · 11.1.0 · 10.0.1
- Website: https://compiler-rt.llvm.org
- Licenses: ASL 2.0
- Package source: gnu/packages/llvm.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of clang-runtime
as follows:
guix install clang-runtime
Or install a particular version:
guix install clang-runtime@10.0.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of clang-runtime about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/clang-runtime'><img src='https://packages.guix.gnu.org/packages/clang-runtime/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/clang-runtime)
Example Org:
[[https://packages.guix.gnu.org/packages/clang-runtime][https://packages.guix.gnu.org/packages/clang-runtime/badges/latest-version.svg]]