clang 3.7.1
C language family frontend for LLVM
Clang is a compiler front end for the C, C++, Objective-C and Objective-C++ programming languages. It uses LLVM as its back end. The Clang project includes the Clang front end, the Clang static analyzer, and several code analysis tools.
- Website: https://clang.llvm.org
- Licenses: NCSA/University of Illinois Open Source License
- Package source: gnu/packages/llvm.scm
- Builds: See build status
- Issues: See known issues
Installation
Install clang 3.7.1
as follows:
guix install clang@3.7.1
Or install the latest version:
guix install clang
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.