This package browser is in early development. Mind the rough edges.

clojure-core-async 1.6.681

Facilities for async programming and communication in Clojure

The core.async library adds support for asynchronous programming using channels to Clojure. It provides facilities for independent threads of activity, communicating via queue-like channels inspired by Hoare’s work on Communicating Sequential Processes (CSP).

Installation

Install clojure-core-async 1.6.681 as follows:

guix install clojure-core-async@1.6.681

Or install the latest version:

guix install clojure-core-async

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.