This package browser is in early development. Mind the rough edges.

clojure-data-xml

Clojure library for reading and writing XML data

data.xml is a Clojure library for reading and writing XML data. data.xml has the following features:

Parses XML documents into Clojure data structures Emits XML from Clojure data structures No additional dependencies if using JDK >= 1.6 Uses StAX internally lazy - should allow parsing and emitting of large XML documents

Installation

Install the latest version of clojure-data-xml as follows:

guix install clojure-data-xml

Or install a particular version:

guix install clojure-data-xml@0.2.0-alpha6

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.