This package browser is in early development. Mind the rough edges.

conan

Decentralized C/C++ package manager

Conan is a package manager for C and C++ developers that boasts the following features:

  • It is fully decentralized. Users can host their packages on their own private servers.

  • It can create, upload and download binaries for any configuration and platform, including cross-compiled ones.

  • It integrates with any build system, including CMake, Makefiles, Meson, etc.

  • It is extensible; its Python-based recipes, together with extensions points allow for great power and flexibility.

Installation

Install the latest version of conan as follows:

guix install conan

Or install a particular version:

guix install conan@2.0.9

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.