dotherside
C language library for creating bindings for the Qt QML language
DOtherSide is a C language library for creating bindings for the QT QML language. The following features are implementable from a binding language:
Creating custom QObject
Creating custom QAbstractListModels
Creating custom properties, signals and slots
Creating from QML QObject defined in the binded language
Creating from Singleton QML QObject defined in the binded language
- Versions: 0.9.0
- Website: https://filcuc.github.io/DOtherSide/index.html
- Licenses: LGPL 3
- Package source: gnu/packages/qt.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of dotherside
as follows:
guix install dotherside
Or install a particular version:
guix install dotherside@0.9.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/dotherside/'><img src='http://127.0.0.1:3000/packages/dotherside/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/dotherside/badges/latest-version.svg)](http://127.0.0.1:3000/packages/dotherside/) Org: [[http://127.0.0.1:3000/packages/dotherside/][http://127.0.0.1:3000/packages/dotherside/badges/latest-version.svg]]