This package browser is in early development. Mind the rough edges.

ecl-cl-num-utils

Numerical utilities for Common Lisp

cl-num-utils implements simple numerical functions for Common Lisp, including:

  • num=, a comparison operator for floats

  • simple arithmeric functions, like sum and l2norm

  • elementwise operations for arrays

  • intervals

  • special matrices and shorthand for their input

  • sample statistics

  • Chebyshev polynomials

  • univariate rootfinding

Installation

Install the latest version of ecl-cl-num-utils as follows:

guix install ecl-cl-num-utils

Or install a particular version:

guix install ecl-cl-num-utils@0.1-1.97a88cd

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.