This package browser is in early development. Mind the rough edges.

eigen 3.4.0

C++ template library for linear algebra

Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms. It provides an elegant API based on "expression templates". It is versatile: it supports all matrix sizes, all standard numeric types, various matrix decompositions and geometry features, and more.

Installation

Install eigen 3.4.0 as follows:

guix install eigen@3.4.0

Or install the latest version:

guix install eigen

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.