eigen 3.4.0
C++ template library for linear algebra
Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms. It provides an elegant API based on "expression templates". It is versatile: it supports all matrix sizes, all standard numeric types, various matrix decompositions and geometry features, and more.
- Website: https://eigen.tuxfamily.org
- Licenses: MPL 2.0
- Package source: gnu/packages/algebra.scm
- Builds: See build status
- Issues: See known issues
Installation
Install eigen 3.4.0
as follows:
guix install eigen@3.4.0
Or install the latest version:
guix install eigen
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.