This package browser is in early development. Mind the rough edges.

emacs-wide-int 28.2

The extensible, customizable, self-documenting text editor (with wide ints)

GNU Emacs is an extensible and highly customizable text editor. It is based on an Emacs Lisp interpreter with extensions for text editing. Emacs has been extended in essentially all areas of computing, giving rise to a vast array of packages supporting, e.g., email, IRC and XMPP messaging, spreadsheets, remote server editing, and much more. Emacs includes extensive documentation on all aspects of the system, from basic editing to writing large Lisp programs. It has full Unicode support for nearly all human languages.

Installation

Install emacs-wide-int 28.2 as follows:

guix install emacs-wide-int@28.2

Or install the latest version:

guix install emacs-wide-int

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.