This package browser is in early development. Mind the rough edges.

fstrm 0.6.1

Implementation of the Frame Streams data transport protocol

fstrm is an optimised implementation of Frame Streams as a C library and several tools built on top of it.

Frame Streams is a light-weight, binary-clean protocol that allows for the transport of arbitrarily-encoded data payload sequences with minimal framing overhead---just four bytes per data frame. It does not specify an encoding format for these data frames and can be used with any data serialisation format that produces byte sequences, such as Protocol Buffers, XML, JSON, MessagePack, YAML, etc.

Frame Streams can be used either as a streaming transport over a reliable byte stream socket (TCP sockets, TLS connections, AF_UNIX sockets, etc.) for data in motion, or as a file format for data at rest.

Installation

Install fstrm 0.6.1 as follows:

guix install fstrm@0.6.1

Or install the latest version:

guix install fstrm

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.