This package browser is in early development. Mind the rough edges.

ghc-abstract-deque

Abstract, parameterized interface to mutable Deques for Haskell

This Haskell package provides an abstract interface to highly-parameterizable queues/deques.

Background: There exists a feature space for queues that extends between:

  • Simple, single-ended, non-concurrent, bounded queues

  • Double-ended, thread-safe, growable queues with important points in between (such as the queues used for work stealing).

This package includes an interface for Deques that allows the programmer to use a single API for all of the above, while using the type system to select an efficient implementation given the requirements (using type families).

This package also includes a simple reference implementation based on IORef and Data.Sequence.

Installation

Install the latest version of ghc-abstract-deque as follows:

guix install ghc-abstract-deque

Or install a particular version:

guix install ghc-abstract-deque@0.3

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

HTML: <a href='http://127.0.0.1:3000/packages/ghc-abstract-deque/'><img src='http://127.0.0.1:3000/packages/ghc-abstract-deque/badges/latest-version.svg'></img></a>
Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/ghc-abstract-deque/badges/latest-version.svg)](http://127.0.0.1:3000/packages/ghc-abstract-deque/)
Org: [[http://127.0.0.1:3000/packages/ghc-abstract-deque/][http://127.0.0.1:3000/packages/ghc-abstract-deque/badges/latest-version.svg]]