ghc-monad-par
Haskell library for parallel programming based on a monad
The Par
monad offers an API for parallel programming. The library works for parallelising both pure and IO
computations, although only the pure version is deterministic. The default implementation provides a work-stealing scheduler and supports forking tasks that are much lighter weight than IO-threads.
- Versions: 0.3.5
- Website: https://github.com/simonmar/monad-par
- Licenses: Modified BSD
- Package source: gnu/packages/haskell-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of ghc-monad-par
as follows:
guix install ghc-monad-par
Or install a particular version:
guix install ghc-monad-par@0.3.5
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of ghc-monad-par about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/ghc-monad-par'><img src='https://packages.guix.gnu.org/packages/ghc-monad-par/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/ghc-monad-par/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/ghc-monad-par)
Example Org:
[[https://packages.guix.gnu.org/packages/ghc-monad-par][https://packages.guix.gnu.org/packages/ghc-monad-par/badges/latest-version.svg]]