ghc-monad-par 0.3.5
Haskell library for parallel programming based on a monad
The Par
monad offers an API for parallel programming. The library works for parallelising both pure and IO
computations, although only the pure version is deterministic. The default implementation provides a work-stealing scheduler and supports forking tasks that are much lighter weight than IO-threads.
- Website: https://github.com/simonmar/monad-par
- Licenses: Modified BSD
- Package source: gnu/packages/haskell-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install ghc-monad-par 0.3.5
as follows:
guix install ghc-monad-par@0.3.5
Or install the latest version:
guix install ghc-monad-par
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.