ghc-reflex 0.8.2.2
Higher-order functional reactive programming
This library lets you write interactive programs without callbacks or side-effects. Functional Reactive Programming (FRP) uses composable events and time-varying values to describe interactive systems as pure functions. Just like other pure functional code, functional reactive code is easier to get right on the first try, maintain, and reuse. Reflex is a fully-deterministic, higher-order FRP interface and an engine that efficiently implements that interface.
- Website: https://reflex-frp.org
- Licenses: Modified BSD
- Package source: gnu/packages/haskell-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install ghc-reflex 0.8.2.2
as follows:
guix install ghc-reflex@0.8.2.2
Or install the latest version:
guix install ghc-reflex
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.