This package browser is in early development. Mind the rough edges.

ghc-sdl2 2.5.5.0

High- and low-level bindings to the SDL library

This package contains bindings to the SDL 2 library, in both high- and low-level forms. The SDL namespace contains high-level bindings, where enumerations are split into sum types, and we perform automatic error-checking. The SDL.Raw namespace contains an almost 1-1 translation of the C API into Haskell FFI calls. As such, this does not contain sum types nor error checking. Thus this namespace is suitable for building your own abstraction over SDL, but is not recommended for day-to-day programming.

Installation

Install ghc-sdl2 2.5.5.0 as follows:

guix install ghc-sdl2@2.5.5.0

Or install the latest version:

guix install ghc-sdl2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.