ghc-statistics 0.16.1.2
Haskell library of statistical types, data, and functions
This library provides a number of common functions and types useful in statistics. We focus on high performance, numerical robustness, and use of good algorithms. Where possible, we provide references to the statistical literature.
The library's facilities can be divided into four broad categories:
Working with widely used discrete and continuous probability distributions. (There are dozens of exotic distributions in use; we focus on the most common.)
Computing with sample data: quantile estimation, kernel density estimation, histograms, bootstrap methods, significance testing, and regression and autocorrelation analysis.
Random variate generation under several different distributions.
Common statistical tests for significant differences between samples.
- Website: https://github.com/haskell/statistics
- Licenses: FreeBSD
- Package source: gnu/packages/haskell-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install ghc-statistics 0.16.1.2
as follows:
guix install ghc-statistics@0.16.1.2
Or install the latest version:
guix install ghc-statistics
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.