This package browser is in early development. Mind the rough edges.

ghc-text-short

Memory-efficient representation of Unicode text strings

This package provides the ShortText type which is suitable for keeping many short strings in memory. This is similar to how ShortByteString relates to ByteString.

The main difference between Text and ShortText is that ShortText uses UTF-8 instead of UTF-16 internally and also doesn't support zero-copy slicing (thereby saving 2 words). Consequently, the memory footprint of a (boxed) {ShortText

Installation

Install the latest version of ghc-text-short as follows:

guix install ghc-text-short

Or install a particular version:

guix install ghc-text-short@0.1.5

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.