This package browser is in early development. Mind the rough edges.

ghc-text-zipper

Text editor zipper library

This Haskell library provides a two-dimensional zipper data structure for editing text. The structure represents the body of text and an editing cursor which can be moved through it, along with a set of editing transformations.

Text zippers are generalized over the set of data types that might be used to store lists of characters (e.g., String, T.Text, etc.). Implementations using both of these examples are provided.

Installation

Install the latest version of ghc-text-zipper as follows:

guix install ghc-text-zipper

Or install a particular version:

guix install ghc-text-zipper@0.12

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.