git-tools 2022.12
Assorted git-related scripts and tools
git-tools
is a collection of bash and python scripts. Specifically, it includes the following tools:
git-branches-rename
: Batch rename branches with a matching prefix to another prefixgit-clone-subset
: Clone a subset of a git repositorygit-find-uncommitted-repos
: Recursively list repositories in the given directory(ies) that have uncommitted changesgit-rebase-theirs
: Resolve rebase conflicts and failed cherry-picks by favoring "theirs" versiongit-restore-mtime
: Restore modification time of files based on the date of the most recent commit that modified themgit-strip-merge
: A git-merge wrapper that deletes files on a "foreign" branch before merging
- Outputs:
out
- Website: https://github.com/MestreLion/git-tools
- Licenses: GPL 3+
- Package source: gnu/packages/version-control.scm
- Builds: See build status
- Issues: See known issues
Installation
Install git-tools 2022.12
as follows:
guix install git-tools@2022.12
Or install the latest version:
guix install git-tools
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.