go 1.22.11
Compiler and libraries for Go, a statically-typed language
Go, also commonly referred to as golang, is an imperative programming language designed primarily for systems programming. Go is a compiled, statically typed language in the tradition of C and C++, but adds garbage collection, various safety features, and concurrent programming features in the style of communicating sequential processes (CSP).
- Outputs:
out
,tests
- Website: https://go.dev/
- Licenses: Modified BSD
- Package source: gnu/packages/golang.scm
- Builds: See build status
- Issues: See known issues
Installation
Install go 1.22.11
as follows:
guix install go@1.22.11
Or install the latest version:
guix install go
The go
package provides more outputs besides the default (out
). You can install them by appending :output-name
to the package specification. For example:
guix install go:tests
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.