guile-smc
GNU Guile state machine compiler
Guile-SMC is a state machine compiler that allows users to describe finite state machines (FSMs) in Scheme in terms of transition tables. It is capable to generate such transition tables from a PlantUML state diagrams.
A transition table can be verified and checked for dead-ends and infinite loops. Also Guile-SMC FSMs gather statistics when they run.
Guile-SMC comes with a Scheme program called smc
-- a state machine compiler itself. It produces a Scheme code for an FSM from the PlantUML format. This tool is meant to be called on a PlantUML file when a program with a FSM is being built (for example, from a Makefile.)
- Versions: 0.6.0
- Website: https://github.com/artyom-poptsov/guile-smc
- Licenses: GPL 3
- Package source: gnu/packages/guile-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of guile-smc
as follows:
guix install guile-smc
Or install a particular version:
guix install guile-smc@0.6.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.