imgui 1.91.4
Immediate-mode C++ GUI library with minimal dependencies
dear imgui
(also know as ImGui) is a graphical user interface library for C++. It creates optimized vertex buffers that you can render anytime in your 3D-pipeline-enabled application. It's fast, portable, renderer-agnostic, and self-contained, without external dependencies.
ImGui is aimed at content creation, visualization, and debugging tools as opposed to average end-user interfaces. Hence it favors simplicity and productivity but lacks certain features often found in higher-level libraries. It is particularly suited to integration in game engine tooling, real-time 3D applications, full-screen applications, and embedded platforms without standard operating system features.
- Website: https://github.com/ocornut/imgui
- Licenses: Expat
- Package source: gnu/packages/toolkits.scm
- Builds: See build status
- Issues: See known issues
Installation
Install imgui 1.91.4
as follows:
guix install imgui@1.91.4
Or install the latest version:
guix install imgui
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.