This package browser is in early development. Mind the rough edges.

java-asm

Very small and fast Java bytecode manipulation framework

ASM is an all purpose Java bytecode manipulation and analysis framework. It can be used to modify existing classes or dynamically generate classes, directly in binary form. The provided common transformations and analysis algorithms allow easily assembling custom complex transformations and code analysis tools.

Installation

Install the latest version of java-asm as follows:

guix install java-asm

Or install a particular version:

guix install java-asm@3.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.