This package browser is in early development. Mind the rough edges.

java-commons-lang 2.6

Extension of the java.lang package

The Commons Lang components contains a set of Java classes that provide helper methods for standard Java classes, especially those found in the java.lang package in the Sun JDK. The following classes are included:

  • StringUtils - Helper for java.lang.String.

  • CharSetUtils - Methods for dealing with CharSets, which are sets of characters such as [a-z] and [abcdez].

  • RandomStringUtils - Helper for creating randomised strings.

  • NumberUtils - Helper for java.lang.Number and its subclasses.

  • NumberRange - A range of numbers with an upper and lower bound.

  • ObjectUtils - Helper for java.lang.Object.

  • SerializationUtils - Helper for serializing objects.

  • SystemUtils - Utility class defining the Java system properties.

  • NestedException package - A sub-package for the creation of nested exceptions.

  • Enum package - A sub-package for the creation of enumerated types.

  • Builder package - A sub-package for the creation of equals, hashCode, compareTo and toString methods.

Installation

Install java-commons-lang 2.6 as follows:

guix install java-commons-lang@2.6

Or install the latest version:

guix install java-commons-lang

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.