This package browser is in early development. Mind the rough edges.

java-gson

Java serialization/deserialization library from/to JSON

Gson is a Java library that can be used to convert Java Objects into their JSON representation. It can also be used to convert a JSON string to an equivalent Java object. Gson can work with arbitrary Java objects including pre-existing objects that you do not have source-code of.

Installation

Install the latest version of java-gson as follows:

guix install java-gson

Or install a particular version:

guix install java-gson@2.8.2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.