This package browser is in early development. Mind the rough edges.

java-javaewah

Compressed alternative to the Java `BitSet' class

This is a word-aligned compressed variant of the Java Bitset class. It provides both a 64-bit and a 32-bit RLE-like compression scheme. It can be used to implement bitmap indexes.

The goal of word-aligned compression is not to achieve the best compression, but rather to improve query processing time. Hence, JavaEWAH tries to save CPU cycles, maybe at the expense of storage. However, the EWAH scheme is always more efficient storage-wise than an uncompressed bitmap (as implemented in the BitSet class by Sun).

Installation

Install the latest version of java-javaewah as follows:

guix install java-javaewah

Or install a particular version:

guix install java-javaewah@1.1.6

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.