java-javaewah 1.1.6
Compressed alternative to the Java `BitSet' class
This is a word-aligned compressed variant of the Java Bitset
class. It provides both a 64-bit and a 32-bit RLE-like compression scheme. It can be used to implement bitmap indexes.
The goal of word-aligned compression is not to achieve the best compression, but rather to improve query processing time. Hence, JavaEWAH tries to save CPU cycles, maybe at the expense of storage. However, the EWAH scheme is always more efficient storage-wise than an uncompressed bitmap (as implemented in the BitSet
class by Sun).
- Outputs:
out
- Website: https://github.com/lemire/javaewah
- Licenses: ASL 2.0
- Package source: gnu/packages/java.scm
- Builds: See build status
- Issues: See known issues
Installation
Install java-javaewah 1.1.6
as follows:
guix install java-javaewah@1.1.6
Or install the latest version:
guix install java-javaewah
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.