This package browser is in early development. Mind the rough edges.

java-la4j 0.6.0

Java library that provides Linear Algebra primitives and algorithms

The la4j library is a Java library that provides Linear Algebra primitives (matrices and vectors) and algorithms. The key features of the la4j library are:

  • No dependencies and tiny size

  • Fluent object-oriented/functional API

  • Sparse (CRS, CCS) and dense (1D/2D arrays) matrices

  • Linear systems solving (Gaussian, Jacobi, Zeidel, Square Root, Sweep and other)

  • Matrices decomposition (Eigenvalues/Eigenvectors, SVD, QR, LU, Cholesky and other)

  • MatrixMarket/CSV IO formats support for matrices and vectors

Installation

Install java-la4j 0.6.0 as follows:

guix install java-la4j@0.6.0

Or install the latest version:

guix install java-la4j

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.