javacc 3.2
Java parser generator
Java Compiler Compiler (JavaCC) is the most popular parser generator for use with Java applications. A parser generator is a tool that reads a grammar specification and converts it to a Java program that can recognize matches to the grammar. In addition to the parser generator itself, JavaCC provides other standard capabilities related to parser generation such as tree building (via a tool called JJTree included with JavaCC), actions, debugging, etc.
- Website: https://javacc.org/
- Licenses: Modified BSD
- Package source: gnu/packages/java.scm
- Builds: See build status
- Issues: See known issues
Installation
Install javacc 3.2
as follows:
guix install javacc@3.2
Or install the latest version:
guix install javacc
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.