libevent
Event notification library
The libevent API provides a mechanism to execute a callback function when a specific event occurs on a file descriptor or after a timeout has been reached. Furthermore, libevent also support callbacks due to signals or regular timeouts.
libevent is meant to replace the event loop found in event driven network servers. An application just needs to call event_dispatch() and then add or remove events dynamically without having to change the event loop.
- Versions: 2.1.12
- Website: https://libevent.org/
- Licenses: Modified BSD
- Package source: gnu/packages/libevent.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of libevent
as follows:
guix install libevent
Or install a particular version:
guix install libevent@2.1.12
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.