This package browser is in early development. Mind the rough edges.

liquidprompt 2.1.2

Full-featured prompt for Bash & Zsh

Liquidprompt is an adaptive prompt for Bash and Zsh that gives you a nicely displayed prompt with useful information when you need it. It does this with a powerful theming engine and a large array of data sources.

In order to use liquidprompt with Zsh, you should use the following snippet with Guix Home:

(service home-zsh-service-type
         (home-zsh-configuration
           (zshrc (list ;;...
                    ;; This loads liquidprompt
                    (mixed-text-file "liquidprompt"
                                     "[[ $- = *i* ]] && source " liquidprompt "/share/liquidprompt/liquidprompt")
                    ;; This loads the powerline theme available in liquidprompt
                    (mixed-text-file "powerline-theme"
                                     "source " liquidprompt "/share/liquidprompt/themes/powerline/powerline.theme"))))))

Installation

Install liquidprompt 2.1.2 as follows:

guix install liquidprompt@2.1.2

Or install the latest version:

guix install liquidprompt

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.