llvm 9.0.1
Optimizing compiler infrastructure
LLVM is a compiler infrastructure designed for compile-time, link-time, runtime, and idle-time optimization of programs from arbitrary programming languages. It currently supports compilation of C and C++ programs, using front-ends derived from GCC 4.0.1. A new front-end for the C family of languages is in development. The compiler infrastructure includes mirror sets of programming tools as well as libraries with equivalent functionality.
- Outputs:
opt-viewer
,out
- Website: https://www.llvm.org
- Licenses: ASL 2.0
- Package source: gnu/packages/llvm.scm
- Builds: See build status
- Issues: See known issues
Installation
Install llvm 9.0.1
as follows:
guix install llvm@9.0.1
Or install the latest version:
guix install llvm
The llvm
package provides more outputs besides the default (out
). You can install them by appending :output-name
to the package specification. For example:
guix install llvm:opt-viewer
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.