mujs 1.3.5
JavaScript interpreter written in C
MuJS is a lightweight Javascript interpreter designed for embedding in other software to extend them with scripting capabilities. MuJS was designed with a focus on small size, correctness, and simplicity. It is written in portable C and implements ECMAScript as specified by ECMA-262. The interface for binding with native code is designed to be as simple as possible to use, and is very similar to Lua. There is no need to interact with byzantine C++ template mechanisms, or worry about marking and unmarking garbage collection roots, or wrestle with obscure build systems.
- Outputs:
out
- Website: https://mujs.com/
- Licenses: ISC
- Package source: gnu/packages/javascript.scm
- Builds: See build status
- Issues: See known issues
Installation
Install mujs 1.3.5
as follows:
guix install mujs@1.3.5
Or install the latest version:
guix install mujs
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.