This package browser is in early development. Mind the rough edges.

node-yazl

Yet another zip library for node

This package provides a zip library for Node. It follows the following principles:

  1. Don't block the JavaScript thread. Use and provide async APIs.

  2. Keep memory usage under control. Don't attempt to buffer entire files in RAM at once.

  3. Prefer to open input files one at a time than all at once.

Installation

Install the latest version of node-yazl as follows:

guix install node-yazl

Or install a particular version:

guix install node-yazl@2.5.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.