This package browser is in early development. Mind the rough edges.

ocaml-ctypes

Library for binding to C libraries using pure OCaml

Ctypes is a library for binding to C libraries using pure OCaml. The primary aim is to make writing C extensions as straightforward as possible. The core of ctypes is a set of combinators for describing the structure of C types -- numeric types, arrays, pointers, structs, unions and functions. You can use these combinators to describe the types of the functions that you want to call, then bind directly to those functions -- all without writing or generating any C!

Installation

Install the latest version of ocaml-ctypes as follows:

guix install ocaml-ctypes

Or install a particular version:

guix install ocaml-ctypes@0.20.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of ocaml-ctypes about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/ocaml-ctypes'><img src='https://packages.guix.gnu.org/packages/ocaml-ctypes/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/ocaml-ctypes/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/ocaml-ctypes)

Example Org:

[[https://packages.guix.gnu.org/packages/ocaml-ctypes][https://packages.guix.gnu.org/packages/ocaml-ctypes/badges/latest-version.svg]]