This package browser is in early development. Mind the rough edges.

ocaml-ctypes 0.20.1

Library for binding to C libraries using pure OCaml

Ctypes is a library for binding to C libraries using pure OCaml. The primary aim is to make writing C extensions as straightforward as possible. The core of ctypes is a set of combinators for describing the structure of C types -- numeric types, arrays, pointers, structs, unions and functions. You can use these combinators to describe the types of the functions that you want to call, then bind directly to those functions -- all without writing or generating any C!

Installation

Install ocaml-ctypes 0.20.1 as follows:

guix install ocaml-ctypes@0.20.1

Or install the latest version:

guix install ocaml-ctypes

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.